Задать вопрос
5 февраля, 23:40

Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения. Если сумма всех чисел не больше 80, то выведите только два первых числа. Если выполняется одновременно два перечисленных выше условия, то выведите только два последних числа. Иначе, выведите все четыре числа, увеличев их на 5

+2
Ответы (1)
  1. 6 февраля, 00:45
    0
    Одна тонкость - разность первых 2-ух чисел это из первого вычитаем второе или из второго первое?

    Program Chisla;

    Uses Crt;

    var a, b, c, d, sum:real;

    begin

    clrscr;

    write ('Введите первое число: ') ;

    readln (a) ;

    write ('Введите второе число: ') ;

    readln (b) ;

    write ('Введите третье число: ') ;

    readln (c) ;

    write ('Введите четвёртое число: ') ;

    readln (d) ;

    sum:=a+b+c+d;

    if ((a-b) >d) and (sum<=80) then writeln (c, d)

    else

    if (a-b) >d then writeln (a, b, c, d)

    else

    if (sum<=80) then writeln (a, b)

    else writeln (a+5, b+5, c+5, d+5) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)