Задать вопрос
8 сентября, 03:50

Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение. Если третье и четвёртое числа больше100, то выведите среднее арифметическое всех пяти чисел. Если выполняются одновременно два перечисленных выше условия, то выведите на экран все пять чисел без изменения. Иначе, выведите третье и пятое числа, увеличив их в два раза.

+4
Ответы (1)
  1. 8 сентября, 05:33
    0
    var a1, a2, a3, a4, a5:real;

    u1, u2:boolean;

    begin

    writeln ('Введите 5 вещественных чисел') ;

    readln (a1, a2, a3, a4, a5) ;

    u1: = (a1<0) and (a2<0) and (a5<0) ;

    u2: = (a3>100) and (a4>100) ;

    if u1 and u2 then writeln (a1,' ', a2,' ', a3,' ', a4,' ', a5)

    else

    if u1 then writeln ('a1*a2*a5=', a1*a2*a5)

    else

    if u2 then writeln ('sr. arifm=', (a1+a2+a3+a4+a5) / 5)

    else writeln (2*a3,' ',2*a5) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)