Задать вопрос
18 января, 16:32

Составьте блок-схемы и программы для решения следующих задач.

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

· Если разность первого и последнего, превышает второе, то выведите второе число.

· Если сумма второго и третьего меньше четвертого числа, то выведите эту сумму.

· Если выполняются одновременно два перечисленных выше условия, то выведите второе число и сумму второго и третьего чисел.

· Иначе, выведите все четыре числа без изменения.

+3
Ответы (1)
  1. 18 января, 18:37
    0
    Если смотреть с точки зрения Паскаля, то получается такая ересь:

    var

    x, z, c, y:real;

    begin

    writeln ('введите первое число') ; readln (x) ;

    writeln ('введите второе число') ; readln (z) ;

    ...

    Q:=x-y; (разность первого и последнего числа) ;

    W:=z+c; (сумма второго и третьего числа) ;

    В случае если выполняются эти два условия

    if Q > z then

    if W < y then

    begin

    writeln (W) ;

    writeln (z) ;

    end

    else

    if Q > z then writeln (z)

    else

    if W < y then writeln (W) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)