Задать вопрос
5 апреля, 20:53

Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа. Если сумма первого и третьего чисел отрицательна, то выведите эти два числа и их сумму. если выполняются одновременно два перечисленных выше условия, то выведите четыре числа без изменения. иначе, выведите сумму этих четырех чисел, уменьшенную в два раза. составьте соответствующие отладочные примеры и проверьте работу каждой программы.

+3
Ответы (1)
  1. 5 апреля, 21:33
    0
    program zadacha_1;

    var n1, n2, n3, n4:integer / / Здесь храним значение 4 чисел

    begin

    writeln ('Введи 4 числа') ;

    readln (n1, n2, n3, n4) ;

    if (n1*n2*n3*n4) >0 then writeln (n1*3,' ', n2*3,' ', n3*3,' ', n4*4)

    else if (n1+n3) <0 then writeln (n1,' ', n3,' их сумма равна ', n1+n3)

    else if ((n1*n2*n3*n4) >0 and (n1+n3) <0) then writeln (n1,' ', n2,' ', n3,' ', n4)

    else writeln ((n1+n2+n3+n4) div 2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)