Задать вопрос
11 марта, 04:34

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.

+4
Ответы (1)
  1. 11 марта, 07:57
    0
    Var a, b, c, d:real;

    begin

    readln (a, b, c, d) ; i

    f (a<0) and (b/c=2) then

    begin

    writeln ((a+b+c+d) / 4) ;

    if a*b*c*b>a+b+c+d then

    begin

    writeln (a*b*c*b) ;

    writeln (a+b+c+d) ;

    end;

    end

    else

    writeln (a*2,' ', b*2,' ', c*2,' ', d*2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)