Задать вопрос
21 октября, 13:03

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.

Если сумма первого и третьего чисел отрицательна, то выведите эти два числа и их сумму.

Если выполняются одновременно два перечисленных выше условия, то выведите четыре числа без изменения.

Иначе, выведите сумму этих четырех чисел, уменьшенную в два раза.

Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

+5
Ответы (1)
  1. 21 октября, 15:14
    0
    Var a, b, c, d, a1, b1, c1, d1:real;

    Begin

    Write ('Введите 4 числа a, b, c, d: ') ; readln (a, b, c, d) ;

    if (a*b*c*d > 0) then begin

    a1:=a*3; b1:=b*3; c1:=c*3; d1:=d*3;

    writeln ('a*3=', a1,' b*3=', b1,'c*3=', c1,'d*3=', d1) ;

    end;

    if (a+c < 0) then writeln ('a+c=', a+c) ;

    if (a+c 0) then writeln (a,' ', b,' ', c,' ', d)

    else writeln ((a+b+c+d) / 2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)