Задать вопрос
20 апреля, 03:43

Найти ср. арифметическое элементов каждой из нечётных строк матрицы n-го порядка.

+5
Ответы (1)
  1. 20 апреля, 06:22
    0
    var a:array[1 ... 100,1 ... 100] of integer;

    i, j, s, n, k:integer;

    Begin

    read (n) ;

    for i: = 1 to n do

    for j: = 1 to n do begin

    read (a[i, j]) ;

    if i mod 2=0 then begin

    k:=k+1;

    s:=s+a[i, j];

    end;

    end;

    writeln (s/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти ср. арифметическое элементов каждой из нечётных строк матрицы n-го порядка. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна. pascal abc
Ответы (1)
Всем Привет! 1. В текстовом файле хранятся квадратные целочисленные матрицы порядка n. Преобразовать файл, удалив из каждой матрицы элементы побочной диагонали.
Ответы (1)