Задать вопрос
26 ноября, 12:17

Для

матрицы размером в n строк и m

столбцов составить алгоритм и программу вычисления:

1) Сумм элементов каждой нечетной строки матрицы

2) Суммы произведений тангенсов элементов четных строк

матрицы.

3) Номера строки и номера столбца максимального элемента нечетных

столбцов матрицы

+5
Ответы (1)
  1. 26 ноября, 14:54
    0
    1)

    program cgt;

    var a:array[1 ... 100,1 ... 100]of integer;

    s, n, m, i, j:integer;

    begin

    read (n, m) ;

    s:=0;

    for i:=1 to n do

    for j:=1 to m do

    read (a[i, j]) ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    if (i mod 2=1) then s:=s+a[i, j];

    end;

    writeln (s) ;

    end.

    2)

    program cgt;

    var a:array[1 ... 100,1 ... 100]of integer;

    n, m, i, j:integer;

    s, p:real;

    begin

    read (n, m) ;

    s:=0;

    for i:=1 to n do

    for j:=1 to m do

    read (a[i, j]) ;

    for i:=1 to n do

    begin

    p:=1;

    if (i mod 2=0) then begin

    for j:=1 to m do

    begin

    p:=p * (sin (a[i, j]*pi/180)) / (cos (a[i, j]*pi/180)) ;

    end;

    s:=s+p;

    end;

    end;

    writeln (s) ;

    end.

    3)

    program cgt;

    var a:array[1 ... 100,1 ... 100]of integer;

    n, m, i, j, max, x, y:integer;

    begin

    read (n, m) ;

    for i:=1 to n do

    for j:=1 to m do

    read (a[i, j]) ;

    max:=a[1,1];

    for i:=1 to n do

    if (i mod 2=1) then begin

    for j:=1 to m do

    if (a[i, j]>=max) then begin

    max:=a[i, j];

    x:=i;

    y:=j;

    end;

    end;

    writeln (x,' ', y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)