Задать вопрос
7 июня, 20:49

Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то

заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов

на - 1. Матрицу распечатать

+4
Ответы (1)
  1. 7 июня, 23:07
    0
    Не самое лучшее решение, но вот:

    const

    n = 2;

    k = 2;

    var

    i, j, s:integer;

    a:array[1 ... n, 1 ... k] of integer;

    begin

    s:=0;

    for i:=1 to n do

    for j:=1 to k do

    begin

    Writeln ('Введите a[', i,',', j,']:') ;

    readln (a[i, j]) ;

    if a[i, j] mod 2=0 then s:=s+a[i, j];

    end;

    if s<0 then

    for i:=1 to n do

    for j:=1 to k do

    if j mod 2=0 then

    a[i, j]:=1;

    if s>=0 then

    for i:=1 to n do

    for j:=1 to k do

    if j mod 2=0 then

    a[i, j]:=-1;

    for i:=1 to n do

    begin

    for j:=1 to k do

    write ('a[':4, i,',', j,']=', a[i, j]) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
В матрице найти сумму элементов четных столбцов. Если эта сумма положительна, то все элементы нечетных строк возвести в квадрат. В противном случае ко всем элементам побочной диагонали прибавить число 2.
Ответы (1)
Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В противном случае все отрицательные элементы матрицы возвести в квадрат.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)