Задать вопрос
18 августа, 12:00

В матрице найти сумму элементов четных столбцов. Если эта сумма положительна, то все элементы нечетных строк возвести в квадрат. В противном случае ко всем элементам побочной диагонали прибавить число 2. Помогите с решением, в прошлый раз была ошибка надо найти именно сумму элементов четных столбцов.

+5
Ответы (1)
  1. 18 августа, 14:28
    0
    Program Djonny1981;

    uses crt;

    const

    m=5;

    var

    a: array[1 ... m, 1 ... m] of integer;

    i, j: integer;

    sum: integer;

    begin

    randomize;

    sum:=0;

    for i:=1 to m do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (101) - 50;

    write (a[i, j]:5) ;

    end;

    writeln () ;

    end;

    for i:=1 to m do

    for j:=1 to m do

    if j mod 2 = 0 then {вот здесь проверка, чётный ли столбец}

    sum : = sum + a[i, j];

    writeln ('Сумма элементов чётных столбцов равна ', sum) ;

    if sum>0 then

    for i:=1 to m do

    for j:=1 to m do

    if i mod 2 = 1 then

    a[i, j]:=a[i, j]*a[i, j]

    else

    for i:=1 to m do

    a[m-i+1, i]:=a[m-i+1, i]+2;

    for i:=1 to m do

    begin

    for j:=1 to m do

    write (a[i, j]:5) ;

    writeln () ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В матрице найти сумму элементов четных столбцов. Если эта сумма положительна, то все элементы нечетных строк возвести в квадрат. В ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В противном случае все отрицательные элементы матрицы возвести в квадрат.
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Помогите написать программу в pascal'e. Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали. В противном случае-заменить элементы четных строк нулями.
Ответы (1)
В какой строчке допущена ошибка в программе, написанной на языке PascalABC? Программа должна высчитывать сумму элементов, стоящих на побочной диагонали в квадратной матрице 6 х6. 1) program diag; 2) var 3) mat:array[1 ... 6,1 ...
Ответы (1)