Задать вопрос
21 октября, 14:18

Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали.

Входные данные

В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100). В следующих N строках записаны строки матрицы, в каждой - по N натуральных чисел, разделённых пробелами.

Выходные данные

Программа должна вывести матрицу, у которой все элементы выше главной диагонали нулевые, а остальные элементы такие же, как в исходной матрице.

+5
Ответы (1)
  1. 21 октября, 16:28
    0
    Program obnulenie;

    var a:array[1 ... 100,1 ... 100] of integer;

    i, j, n:integer;

    begin

    writeln ('Введите размер квадратной матрицы:') ;

    readln (n) ;

    writeln ('Введите матрицу:') ;

    for i:=1 to n do

    for j:=1 to n do

    begin

    read (a[i, j]) ;

    if j>i then a[i, j]:=0;

    end;

    writeln ('Измененная матрица:') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (a[i, j],' ') ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M (1 ≤ N, M ≤ 100).
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)