Задать вопрос
18 февраля, 22:47

Напишите программу, которая выводит номера элементов массива, равных заданному значению X.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X. Гарантируется, что 0 < N ≤ 10000.

Выходные данные

Программа должна вывести в одной строке номера элементов массива, равных X, разделив их пробелами. Предполагается, что нумерация начинается с единицы. Если таких элементов нет, нужно вывести число - 1.

Примеры

входные данные

5

1 2 1 3 5

1

выходные данные

1 3

+5
Ответы (1)
  1. 19 февраля, 00:10
    0
    Var a:array[1 ... 10000] of integer;

    n, x, i, k:integer;

    begin

    read (n) ;

    k:=0;

    for i:=1 to n do read (a[i]) ;

    read (x) ;

    for i:=1 to n do

    if a[i]=x then begin

    k:=k+1;

    write (i,' ') ;

    end;

    if k=0 then write (-1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Питон Напишите программу, которая находит в массиве количество элементов, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Python! Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)