Задать вопрос
12 апреля, 20:17

Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. Гарантируется, что 0 < N ≤ 10000.

Выходные данные

Программа должна вывести в одну строчку все элементы построенного массива, разделив их пробелами.

Примеры

входные данные

6

1 2 3 4 5 6

выходные данные

1 4

+3
Ответы (1)
  1. 12 апреля, 23:34
    0
    Program a;

    var i, n, c: integer;

    mas1, mas2 : array[1 ... 10000] of integer;

    begin c:=1;

    write ('размер массива = ') ;

    read (n) ;

    writeln ('элементы массива: ') ;

    for i:=1 to n do begin

    read (n) ;

    if (n>0) and (n<=10000) then begin

    mas1[c]:=n;

    inc (c) ;

    end;

    end;

    n:=1;

    writeln ('Выходные данные: ') ;

    i:=1;

    while i< = (c-1) do begin

    mas2[n]:=mas1[i];

    inc (n) ;

    i : = i + 3;

    end;

    for i:=1 to n-1 do

    write (mas2[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. Входные данные Первая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Python! Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)