Задать вопрос
25 октября, 21:17

Pascal ABC

Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. Гарантируется, что 0 < N ≤ 10000.

Выходные данные

Программа должна вывести элементы полученного массива в одной строке, разделив их пробелами.

Примеры

входные данные

6

6 2 1 5 3 4

выходные данные

1 2 3 6 5 4

+4
Ответы (1)
  1. 25 октября, 22:43
    0
    Var

    a: array [1 ... 10000] of integer;

    i, j, k, m, n:integer;

    begin

    read (n) ;

    for i : = 1 to n do

    read (a[i]) ;

    for i : = 1 to 3 do

    begin

    m : = a[i];

    k : = i;

    for j : = i+1 to n do

    if a[j] < m then

    begin

    m : = a[j];

    k : = j

    end;

    for j : = k downto i+1 do

    a[j] : = a[j-1];

    a[i] : = m

    end;

    for i : = 1 to n do

    write (a[i],' ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Python! Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Питон Напишите программу, которая находит в массиве количество элементов, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)