Задать вопрос
30 июля, 01:29

Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.

Входные данные

Первая строка входного файла input. txt содержит размер массива. Во второй строке записаны все элементы массива, разделённые пробелами.

Выходные данные

Программа должна вывести в файл output. txt все элементы отсортированного массива в одной строке, разделив их пробелами.

Примеры

входные данные

5

5 1 4 2 3

выходные данные

1 2 3 4 5

Free Pascal 2.6.2

+2
Ответы (1)
  1. 30 июля, 02:31
    0
    Program n1;

    type z = array of integer;

    var a: z;

    i, n, x, j, buf: integer;

    f: text;

    begin

    randomize;

    assign (f,'input. txt') ;

    reset (f) ;

    n:=0;

    readln (f, x) ;

    setlength (a, x) ;

    while not eof (f) do

    begin

    read (f, a[n]) ;

    n:=n+1;

    end;

    close (f) ;

    for i:=0 to n-2 do

    for j:=i+1 to n-1 do

    if a[i]>a[j] then begin

    buf:=a[i];

    a[i]:=a[j];

    a[j]:=buf;

    end;

    assign (f,'output. txt') ;

    rewrite (f) ;

    for i:=0 to x-1 do write (f, a[i],' ') ;

    close (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)