Задать вопрос
22 ноября, 20:57

Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.

Входные данные

Все элементы массива записаны по одному в каждой строке входного файла input. txt. Ввод завершается числом 0.

Выходные данные

Программа должна вывести в файл output. txt все элементы отсортированного массива в одной строке, разделив их пробелами.

Примеры

входные данные

5

1

-4

-2

3

0

выходные данные

-4 - 2 1 3 5

+4
Ответы (1)
  1. 22 ноября, 23:27
    0
    Program n1;

    type z = array of integer;

    var a: z;

    i, n, j, buf, t: integer;

    f: text;

    begin

    assign (f,'input. txt') ;

    reset (f) ;

    n:=1;

    t:=0;

    while true do

    begin

    readln (f, t) ;

    if (t0) then

    begin

    setlength (a, n) ;

    a[n-1]:=t;

    end else break;

    n:=n+1;

    end;

    close (f) ;

    for i:=0 to n-3 do

    for j:=i+1 to n-2 do

    if a[i]>a[j] then begin

    buf:=a[i];

    a[i]:=a[j];

    a[j]:=buf;

    end;

    assign (f,'output. txt') ;

    rewrite (f) ;

    for i:=0 to n-2 do write (f, a[i],' ') ;

    close (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Решето Эратосфена в PascalABC Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)