Задать вопрос
21 июля, 14:55

Решето Эратосфена в PascalABC

Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия.

Напишите программу, которая выводит все простые числа в диапазоне от 2 до N включительно (2 ≤ N ≤ 100000).

Входные данные

Входная строка содержит целое число N (2 ≤ N ≤ 100000).

Выходные данные

Программа должна вывести все простые числа в диапазоне от 2 до N в одну строку, разделив их пробелами.

Примеры

Входные данные: 20

Выходные данные: 2 3 5 7 11 13 17 19

+4
Ответы (1)
  1. 21 июля, 18:31
    0
    Program n1;

    var n, i: longint;

    function simply (a: longint) : boolean;

    var i: longint;

    begin

    simply:=true;

    for i:=2 to trunc (sqrt (a)) do begin if a mod i=0 then begin

    simply:=false;

    break

    end

    end

    end;

    begin

    readln (n) ;

    for i:=2 to n do if simply (i) then write (i,' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решето Эратосфена в PascalABC Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)