Задать вопрос
10 апреля, 23:43

В PascalABC

Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).

Выходные данные

Программа должна вывести все простые числа, у которых одинаковые первая и последняя цифры десятичной записи, в диапазоне от K до N в одну строку, разделив их пробелами. Если таких чисел нет, нужно вывести число 0.

Примеры

входные данные

100 200

выходные данные

101 131 151 181 191

входные данные

20 30

выходные данные

0

+4
Ответы (1)
  1. 11 апреля, 01:36
    0
    Program n1;

    var k, n, i: longint;

    co: byte;

    function simply (a: longint) : boolean;

    var i: longint;

    begin

    simply:=true;

    for i:=2 to trunc (sqrt (a)) do begin if a mod i=0 then begin

    simply:=false;

    break

    end

    end

    end;

    function cr (a: longint) : boolean;

    var n: longint;

    begin

    n:=a;

    cr:=false;

    repeat

    n:=n div 10;

    until n mod 10 = n;

    if n = (a mod 10) then

    begin

    cr:=true;

    end;

    end;

    begin

    readln (k, n) ;

    for i:=k to n do if simply (i) then begin if (i=2) or (i=3) or (i=5) or (i=7) or cr (i) then

    begin

    write (i,' ') ;

    co:=1;

    end

    end;

    if co=0 then write (0) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. Входные данные: Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Напишите программу, которая выводит все простые числа, у которых цифры стоят строго в порядке убывания, в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (2)
Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно). Входные данные Входная строка содержит целое число N.
Ответы (1)