Задать вопрос
1 июля, 11:11

Напишите программу, которая выводит все простые числа, у которых цифры стоят строго в порядке убывания, в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).

Выходные данные

Программа должна вывести все простые числа, у которых цифры стоят строго в порядке убывания, в диапазоне от K до N в одну строку, разделив их пробелами. Если таких чисел нет, нужно вывести число 0.

+5
Ответы (2)
  1. 1 июля, 12:35
    0
    Class Primes{

    public static void main (String args[]) {

    boolean noPrimes = true;

    java. util. Scanner in = new java. util. Scanner (System. in) ;

    searchPrimes:

    for (int k = in. nextInt (), n = in. nextInt () ; k>=n; k--) {

    for (int p = k/2; p>1; p--) if (k%p==0) continue searchPrimes;

    System. out. print (k+" ") ; noPrimes = false;

    }

    if (noPrimes) System. out. println ("0") ;

    }

    }
  2. 1 июля, 14:13
    0
    Function prime (x:integer) : boolean;

    var

    t:boolean;

    d:integer;

    begin

    t : = true;

    d : = 2;

    while t and (d*d < = x) do

    begin

    if x mod d = 0 then

    t : = false;

    d : = d + 1

    end;

    prime : = t

    end;

    function order (x:integer) : boolean;

    var

    t:boolean;

    d:integer;

    begin

    d : = - 1;

    repeat

    t : = x mod 10 > d;

    d : = x mod 10;

    x : = x div 10

    until not t or (x = 0) ;

    order : = t

    end;

    var

    t:boolean;

    i, k, n:integer;

    begin

    t : = false;

    read (k, n) ;

    for i : = k to n do

    if prime (i) then

    if order (i) then

    begin

    write (i,' ') ;

    t : = true

    end;

    if not t then

    write (0)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит все простые числа, у которых цифры стоят строго в порядке убывания, в диапазоне от K до N (2 ≤ K ≤ N ≤ ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. Входные данные: Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно). Входные данные Входная строка содержит целое число N.
Ответы (1)