Задать вопрос
7 сентября, 07:12

Написать программу, которая решает уравнение ax + b < 0 относительно x для любых чисел a и b, введёных с клавиатуры.

+1
Ответы (1)
  1. 7 сентября, 10:58
    0
    ax + b < 0

    ax < - b

    x < - b / a

    Целые числа.

    Язык программирования: Паскаль

    var

    a, b : integer;

    begin

    readln (a) ;

    readln (b) ;

    if (a = 0) and (b < 0) then

    writeln ('x - любое число') ;

    if (a = 0) and (b > = 0) then

    writeln ('нет решений') ;

    if a 0 then

    writeln ('x < ', - b / a)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая решает уравнение ax + b < 0 относительно x для любых чисел a и b, введёных с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
составьте программу которая получает на вход с клавиатуры три неотрицательных целых числа a, b, c, (каждое число с новой строки) и выводит на экран число 1. Если сумма двух каких либо введеных чисел меньше 100.
Ответы (1)
Составить программу которая определяет среди введеных с клавиатуры целых чисел количества нечетных, до ввода числа 0 PascalABC
Ответы (1)
Составить программу которая определяет среди введеных с клавиатуры целых чисел количества нечетных до ввода числа 0
Ответы (1)