Задать вопрос
24 января, 00:02

1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры.

2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры.

3. Написать программу, вычисляющую среднее арифметическое чисел, принадлежащих диапазону [-5; 5], среди пяти, вводимых с клавиатуры

+5
Ответы (1)
  1. 24 января, 00:24
    0
    Program z1;

    var a, i, sum:integer;

    Begin

    sum:=0;

    for i:=1 to 5 do

    begin;

    read (a) ;

    if (a<0) and (a mod 5=0) then

    sum:=sum+a;

    end;

    writeln (sum) ;

    End.

    Program z2;

    var a, p, i:integer;

    Begin

    p:=1;

    for i: = 1 to 5 do

    begin;

    read (a) ;

    if (a mod 10=2) or (a mod 10=4) then

    p:=p*a;

    end;

    writeln (p) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Написать программу на Паскале: Среди 10 целых положительных и отрицательных чисел: 1. Найти максимальное и минимальное значения. 2. Среднее арифметическое среди трехзначных, оканчивающихся на 1 и кратных 7.
Ответы (2)
Составить программу, вычисляющую среднее арифметическое n чисел, вводимых с клавиатуры. Паскаль.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух положительных чисел X и Y (X и Y - входные, AMean и GMean - выходные параметры вещественного типа).
Ответы (1)