Задать вопрос
12 января, 19:01

Написать программу на Паскале: Среди 10 целых положительных и

отрицательных чисел:

1. Найти

максимальное и минимальное значения.

2. Среднее арифметическое среди трехзначных,

оканчивающихся на 1 и кратных 7.

+1
Ответы (2)
  1. 12 января, 19:49
    0
    Program aliona;

    const n=10;

    var a : array[1 ... n] of inreger;

    min, max, i:integer;

    begin

    randomize;

    for i : = 1 to n do

    begin

    a[i]:=random (100) + 1;

    write (' ', a[i]) ;

    end;

    min:=a[1];

    for i:=1 to n do

    if a[i]
    max:=a[1];

    for i : = 1 to n do

    if a[i]>a[1] then max:=a[i];

    writeln ('min=', min,'max=', max) ;

    readln;

    end,
  2. 12 января, 20:24
    0
    Var

    i, e, min, max, s, n: integer;

    c: real;

    begin

    min : = 32767; max : = - 32768; s : = 0; n : = 0;

    Write ('Введите 10 чисел через пробел ') ;

    for i : = 1 to 10 do

    begin

    Read (e) ;

    if max < e then max : = e;

    if min > e then min : = e;

    if (e > = 100) and (e < = 999) then

    if (i mod 10 = 1) and (i mod 7 = 0) then

    begin n : = n + 1; s : = s + i end

    end;

    Writeln ('max=', max, ', min=', min) ;

    if n > 0 then Writeln ('Искомое среднее равно ', s / n:0:5)

    else Writeln ('Нет трехзначных чисел, оканчивающихся на 1 и кратных 7')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале: Среди 10 целых положительных и отрицательных чисел: 1. Найти максимальное и минимальное значения. 2. Среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)
Ответы (1)