Задать вопрос
11 сентября, 06:56

Напишите программу на Паскале.

Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел.

А[1 ... 10]

+2
Ответы (1)
  1. 11 сентября, 08:11
    0
    Const m=10;

    var

    a:array[1 ... m] of integer;

    i, sum, proz:integer;

    begin

    sum:=0;

    proz:=1;

    for i:=1 to m do

    begin

    read (a[i]) ;

    if a[i]>0 then

    sum:=sum+a[i]

    else

    ifa[i]<0 then

    proz:=proz*a[i];

    end;

    writeln ('Сумма положительных чисел = ', sum,' Произведение отрицательных чисел = ', proz) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)