Задать вопрос
26 января, 23:21

Хотя бы 3-4 задачи!

1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5).

2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.

3) Дан одномерный целочисленный массив А, состоящий из N элементов. Найдите произведение всех нечетных элементов массива.

4) Дан двумерный массив размерностью NXM, заполненный случайными числами. Заменить все четные элементы массива на 2, а нечетные на 1. На экран вывести исходный и новый массив.

5) Дан двумерный массив размерностью NXM, заполненный случайными числами. Напишите программу, в результате выполнения которой все элементы массива увеличиваются в 2 раза. На экран вывести исходный и новый массив.

+1
Ответы (1)
  1. 27 января, 02:22
    0
    Сделал все!) поставь наилучшее!

    1) var a:array [0 ... 5] of Integer; i, j:Integer;

    begin

    Randomize;

    j:=0;

    for i:=0 to 5 do

    a[i]:=Random (100) ;

    for i:=0 to 5 do

    if a[i] mod 3 = 0 then

    Inc (j) ;

    Writeln (j) ;

    readln;

    2) var a:array [0 ... 5] of Integer; i, j:Integer;

    begin

    Randomize;

    j:=0;

    for i:=0 to 5 do

    a[i]:=Random (100) ;

    for i:=0 to 5 do

    if a[i] mod 2 = 0 then

    j:=j+a[i];

    Writeln (j) ;

    readln;

    3) a:array [0 ... 5] of Integer; i, s:Integer;

    begin

    Randomize;

    s:=1;

    for i:=0 to 5 do

    a[i]:=Random (9) + 1;

    for i:=0 to 5 do

    if i mod 2 0 then

    s:=s*a[i];

    Writeln (s) ;

    readln;

    end.

    4) const n=5; m=5;

    var a:array [0 ... n, 0 ... m] of Integer; i, j:Integer;

    begin

    Randomize;

    for i:=0 to n do

    for j:=0 to m do

    a[i, j]:=Random (100) ;

    for i:=0 to n do

    begin

    Writeln;

    for j:=0 to m do

    write (a[i, j]:3) ;

    end;

    for i:=0 to n do

    for j:=0 to m do

    begin

    if a[i, j] mod 2 = 0 then

    a[i, j]:=2

    else if a[i, j] mod 2 0 then

    a[i, j]:=1;

    end;

    Writeln;

    for i:=0 to n do

    begin

    Writeln;

    for j:=0 to m do

    write (a[i, j]:3) ;

    end;

    Readln;

    end.

    5) const n=5; m=5;

    var a:array [0 ... n, 0 ... m] of Integer; i, j:Integer;

    begin

    Randomize;

    for i:=0 to n do

    for j:=0 to m do

    a[i, j]:=Random (10) ;

    for i:=0 to n do

    begin

    Writeln;

    for j:=0 to m do

    write (a[i, j]:3) ;

    end;

    for i:=0 to n do

    for j:=0 to m do

    a[i, j]:=a[i, j]*2;

    Writeln;

    for i:=0 to n do

    begin

    Writeln;

    for j:=0 to m do

    write (a[i, j]:3) ;

    end;

    Readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Задача 1. Дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от - 15 до + 50. Вычислить сумму всех элементов массива, определить количество элементов массива кратных 3.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)