Задать вопрос
9 февраля, 00:19

Задача 1.

Дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от - 15 до + 50. Вычислить сумму всех элементов массива, определить количество элементов массива кратных 3. Исходный массив и результат подсчета (количество и сумма) вывести на экран.

Задача 2.

Упорядочить массив из 20 целых чисел по убыванию. Исходный и упорядоченный массив вывести на экран.

Задача 3.

Составьте программу, которая по фамилии, имени и отчеству человека выводит на экран фамилию и инициалы человека.

например, Иванов Петр Степанович должно получиться на экране Иванов П. С.

+4
Ответы (1)
  1. 9 февраля, 02:16
    0
    1) var

    a: array [1 ... 30] of integer;

    i, s, k: integer;

    begin

    for i : = 1 to 30 do//заполнение рандомными числами (от - 15 до 50, включая и - 15 и 50) массив

    a[i] : = random (-15, 50) ;

    for i : = 1 to 30 do//сумма элементов и подсчет кратных 3

    begin

    s : = s + a[i]; //сумма элементов

    if a[i] mod 3 = 0 then//подсчет кол во кратных 3

    k : = k + 1;

    end;

    writeln ('Исходный массив') ;

    for i : = 1 to 30 do

    writeln ('A[', i, '] = ', a[i]) ;

    writeln ('Сумма элементов массива: ', s) ;

    writeln ('Кратных 3: ', k) ;

    end.

    извини помог бы дальше но дела но вот подсказки:

    2) метод пузырька посмотри

    3) там через функцию поиска и удаления

    если над у меня есть группа в вк называется просто программки если интересно можешь глянуть
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 1. Дан массив из 30 элементов, заполненный целыми случайными числами из диапазона от - 15 до + 50. Вычислить сумму всех элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)