Задать вопрос
20 апреля, 15:11

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива

дан целочисленный

массив из 10 элементов написать программу находящую сумму элементов

массива красных 3 ил 5

дан целочисленный массив из 30 ти элементов

написать программу которая позволяет найти среднее арифметическое

положительных элементов массива

+5
Ответы (1)
  1. 20 апреля, 18:51
    0
    Тебе на поскале судя по всему надо, я его давно изучал синтаксис позабыл но алгоритм могу подсказать

    1)

    Var arr:массив (от 0 до 6) ;

    begin

    пока i<6 / / ввод массива

    readln (arr[i]) ;

    конец;

    writeln ((i[1]+i[5]) / 2) ; / / вывод среднего числа

    end.

    2) задача описана некорректно

    3)

    Var arr:массив (от 0 до 29), n:integer;

    begin

    пока i<30 / / ввод массива

    readln (arr[i]) ;

    конец;

    пока j<29

    n=n+arr[j];

    конец;

    writeln (N/30) ; / / вывод среднего числа

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1). Дан массив из n элементов (n > = 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива. 2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)