Задать вопрос
10 октября, 21:48

Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух положительных чисел X и Y (X и Y - входные, AMean и GMean - выходные параметры вещественного типа). С помощью этой процедуры найти среднее арифметическое и среднее геометрическое для пар (A, B), (A, C), (A, D), если даны A, B, C, D

+3
Ответы (1)
  1. 10 октября, 22:01
    -1
    Procedure Mean (X, Y:real; Var AMean, GMean:real) ;

    Begin

    AMean: = (X+Y) / 2;

    GMean:=Sqrt (X*Y) ;

    End;

    Var

    A, B, C, D, S:real;

    Begin

    Write ('A = ') ; ReadLn (A) ;

    Write ('B = ') ; ReadLn (B) ;

    Write ('C = ') ; ReadLn (C) ;

    Write ('D = ') ; ReadLn (D) ;

    WriteLn;

    Mean (A, B, S, B) ;

    WriteLn ('AMean (A, B) = ', S) ;

    WriteLn ('GMean (A, B) = ', B) ;

    WriteLn;

    Mean (A, C, S, C) ;

    WriteLn ('AMean (A, C) = ', S) ;

    WriteLn ('GMean (A, C) = ', C) ;

    WriteLn;

    Mean (A, D, S, D) ;

    WriteLn ('AMean (A, D) = ', S) ;

    WriteLn ('GMean (A, D) = ', D) ;

    End.

    A = 1

    B = 2

    C = 3

    D = 4

    AMean (A, B) = 1.5

    GMean (A, B) = 1.4142135623731

    AMean (A, C) = 2

    GMean (A, C) = 1.73205080756888

    AMean (A, D) = 2.5

    GMean (A, D) = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Описать процедуру RectDiag (a, b, d), вычисляющую диагональ прямоугольника со сторонами a, b (a, b - входные, d - выходной параметр вещественного типа).
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Описать процедуру PowerA3 (A, B), вычисляющую третью степень числа A и возвращающую ее в переменной B (A - входной, B - выходной параметр; оба параметра являются вещественными). С помощью этой процедуры найти третьи степени пяти данных чисел
Ответы (1)