Задать вопрос
31 августа, 05:51

Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно).

Входные данные

Входная строка содержит целое число N.

Выходные данные

Программа должна вывести все простые числа в диапазоне от 2 до N в одну строку, разделив их пробелами.

Примеры

входные данные

20

выходные данные

2 3 5 7 11 13 17 19

+4
Ответы (1)
  1. 31 августа, 06:41
    0
    Var

    A, N, d:integer;

    Begin

    Write ('N = ') ; ReadLn (N) ;

    For N: = 2 to N do

    Begin

    d:=0;

    A:=2;

    Repeat

    if N mod A = 0 then d:=d+1;

    A:=A+1

    Until A>Sqrt (N) + 1;

    if d = 0 then Write (N,' ')

    End

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит все простые числа в диапазоне от 2 до N (N заранее неизвестно). Входные данные Входная строка содержит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая выводит все простые числа Софи Жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)
Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), оканчивающиеся на цифру 3. Входные данные: Входная строка содержит два натуральных числа, разделённые пробелом, K и N (2 ≤ K ≤ N ≤ 100000).
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)