Задать вопрос
8 апреля, 12:44

Программа паскаль. В диапазоне чисел, введеных клавиатурой, выбрать все нечетные числа и посчитать их кол-во. Если их больше 10, то показать наибольшее из них, иначе - показать сумму четных чисел.

+2
Ответы (1)
  1. 8 апреля, 16:27
    0
    Var

    min, summ, count, maxn, max, i:integer;

    begin

    summ:=0;

    count:=0

    maxn:=0;

    writeln ('Введите диапазон чисел: ') ;

    read (min, max) ;

    for i:=min to max do

    begin

    if ((i mod 2) = 0) then

    summ:=summ+i

    else

    begin

    if (i>maxn) then

    maxn:=i;

    count:=count+1;

    end;

    end;

    if (count>10) then

    writeln (maxn)

    else

    writeln (summ) ;

    end.

    Если нужны какие-то объяснения - пиши в комментарии.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа паскаль. В диапазоне чисел, введеных клавиатурой, выбрать все нечетные числа и посчитать их кол-во. Если их больше 10, то ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано".
Ответы (1)