Задать вопрос
26 декабря, 04:50

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

+3
Ответы (1)
  1. 26 декабря, 08:18
    0
    Program ugadai;

    uses crt;

    var

    i, z, o:integer;

    begin

    randomize;

    writeln ('Введите число от 0 до 99:') ;

    z:=random (100) ;

    for i: = 1 to 10 do

    begin

    read (o) ;

    if (o = z) then

    begin

    writeln ('Вы угадали!') ;

    break;

    end else begin

    if (i = 10) then begin

    writeln ('Жалко, но число не отгаданно. Загаданное число было ', z) ;

    end else begin

    writeln ('Упс! У вас еще ',10 - i,' попопыток. Введите число:') ;

    end;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая требует у вас пароль, например, 246. Если пароль правильный, то выводит сообщение : "молодец!", иначе - "неверный пароль". Если после пятой попытки пароль все равно неверен, выводит сообщение : "карта заблокирована".
Ответы (1)
Прога, которая определяет количество чисел, оканчивающихся на 5, прога получает на вход кол во чисел, а затем сами числа, программа должна вывести одно число-количество чисел оканчивающихся на 5
Ответы (1)
Котик загадывает случайное число от 1 до 10. Это число записано в переменной. Котик тебя спрашивает: Какое число я загадал? А затем сравнивает твой ответ с числом, которое загадал. Если твой ответ равен числу, то ты выиграл.
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
Паскаль ABC Пользователь вводит с клавиатуры два числа. Если сумма чисел больше, либо равна 100, то программа выводит "Разряд выше десятков", если сумма меньше 100, но больше либо равна 10, то программа выводит "Разряд выше единиц", если сумма чисел
Ответы (1)