Задать вопрос
18 мая, 01:55

Напишите программу, которая требует у вас пароль, например, 246. Если пароль правильный, то выводит сообщение : "молодец!", иначе - "неверный пароль". Если после пятой попытки пароль все равно неверен, выводит сообщение : "карта заблокирована".

+4
Ответы (1)
  1. 18 мая, 05:08
    0
    Program n1;

    var pas: string;

    k: integer;

    begin

    readln (pas) ;

    k:=0;

    while true do if pas='246' then

    begin

    write ('молодец') ;

    break;

    end else

    begin

    k:=k+1;

    writeln ('неверный пароль') ;

    readln (pas) ;

    if k=5 then begin write ('карта заблокирована') ;

    break;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая требует у вас пароль, например, 246. Если пароль правильный, то выводит сообщение : "молодец!", иначе - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С помощью оператора repeat напишите программу, которая требует у вас пароль, например 111, и если пароль правильный, то печатает сообщение "Молодец"!
Ответы (1)
Пароль Игорь придумал пароль из 16 символов, состоящий из цифр и английских букв. Чтобы его не забыть, он решил записать пароль, но предварительно хочет его зашифровать.
Ответы (1)
Ввести с клавиатуры пароль (символьную строку). Если его длина меньше, чем 6 символов, вывести сообщение "Слишком короткий пароль!". Если пароль начинается с букв "qwerty" вывести сообщение "Ненадёжный пароль!".
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)