Задать вопрос
23 ноября, 05:49

Ввели 3 числа a, b, c, вычислить b2-4ac и вычислить является ли это число положительным, или отрицательным. Решение с помощью паскаля.

+2
Ответы (2)
  1. 23 ноября, 07:28
    0
    Program a1; / / a1 - название твоей проги, с помощью program задают название программы.

    var a, b, c, s : integer; / / a, b, c, s - переменные. var - ключевое слово, после этого слова объявляют переменные.

    begin / / begin и end - это как скобки, в которых ты решаешь выражение

    readln (a) ;

    readln (b) ;

    readln (c) ;

    / / readln () - оператор, с помощью которого можно отправлять данные в компьютер. Есть и такая fорма записи. read (). Отличие read от readln в том, если использует второй вариант readln (), то каретка (_) переносится на новую строку.

    s : = b*2-4*a*a; / / присваиваем значения переменных в переменную s.

    if (s > 0) then / / конструкция if else позволяет проверять условия, если это равно или не равно, то делай компьютер другое ...

    writeln (' Число положительное') ;

    else if (s < 0) then

    writeln (' Число отрицательное') ;

    / / writeln () выводит инfу на экран.

    end.
  2. 23 ноября, 07:40
    0
    Var

    a, b, c, d: real;

    begin

    write ('Enter a, b, c: ') ;

    read (a, b, c) ;

    d : = b * b - 4 * a * c;

    if d > 0 then writeln ('D is positive')

    else if d = 0 then writeln ('D = 0')

    else writeln ('D is negative')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввели 3 числа a, b, c, вычислить b2-4ac и вычислить является ли это число положительным, или отрицательным. Решение с помощью паскаля. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. (x делится без остатка на 2 и на 3) записать на языке паскаля. 2. (х не делится на 5) записать на языке паскаля. 3. (величина х не кратна 3) записать на языке паскаля.
Ответы (1)
1) Определить, является ли введенное с клавиатуры число четным? 2) Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
Ответы (1)
Решить задачи: 1. Дано целое число. Если оно является положительным, то прибавить к нему 8, если нет, то не изменять. Вывести полученное число. 2. Дано целое чило.
Ответы (1)
Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра.
Ответы (1)
PascalABS составить программу которая определяет 1) является ли число положительным или отрицательным. 2) считает числа отрицательные и положительные. 3) считает сумму отрицательных и положительных
Ответы (1)