Задать вопрос
18 июня, 08:52

PascalABS составить программу которая определяет 1) является ли число положительным или отрицательным. 2) считает числа отрицательные и положительные. 3) считает сумму отрицательных и положительных

+4
Ответы (1)
  1. 18 июня, 10:35
    0
    Var a, i, k1, k2, s1, s2:integer;

    begin

    for i:=1 to 3 do begin

    readln (a) ;

    if a>0 then begin

    writeln ('Число ', a,' положительное') ;

    k1:=k1+1; s1:=s1+a;

    end else if a<0 then begin

    writeln ('Число ', a,' отрицательное') ;

    k2:=k2+1; s2:=s2+a;

    end;

    end;

    writeln ('Количество положительных = ', k1,', их сумма = ', s1) ;

    writeln ('Количество отрицательных = ', k2,', их сумма = ', s2) ;

    end.

    Пример:

    15

    Число 15 положительное

    -74

    Число - 74 отрицательное

    28

    Число 28 положительное

    Количество положительных = 2, их сумма = 43

    Количество отрицательных = 1, их сумма = - 74
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «PascalABS составить программу которая определяет 1) является ли число положительным или отрицательным. 2) считает числа отрицательные и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, которая вводит, число, и определяет, является ли число положительным, отрицательным или равным нулю.
Ответы (2)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Напишите программу, которая запрашивает целое число и определяет, является оно положительным, отрицательным или нулем.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)