Задать вопрос
13 сентября, 19:35

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом.

8 класс.

+1
Ответы (1)
  1. 13 сентября, 20:07
    0
    1)

    var a: integer;

    begin

    write ('Введите число: ') ;

    read (a) ;

    if (a div 10 + a mod 10 + a div 10 mod 10) mod 2 = 0

    then writeln ('Сумма цифр четна')

    else writeln ('Сумма цифр нечетна')

    end.

    2)

    var a: integer;

    begin

    write ('Введите число: ') ;

    read (a) ;

    if a mod 2 = 0 then writeln ('Последняя цифра числа четная')

    else writeln ('Последняя цифра числа нечетная')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы