Задать вопрос
24 августа, 19:56

Составте программу в паскале которая определяет, является ли сумма цифр введеного целого трёхзначного числа чётным числом

+5
Ответы (1)
  1. 24 августа, 22:48
    0
    Var a, s:integer;

    begin

    readln (a) ;

    a:=abs (a) ;

    s: = (a div 100) + (a div 10 mod 10) + (a mod 10) ;

    if s mod 2=0 then writeln ('s = ', s,' - четное значение')

    else writeln ('s = ', s,' - нечетное значение') ;

    end.

    Пример:

    394

    s = 16 - четное значение
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу в паскале которая определяет, является ли сумма цифр введеного целого трёхзначного числа чётным числом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Как составить программу, которая определяет является ли сумма цифр введённого целого трёхзначного числа четным числом?
Ответы (1)
составьте программу которая определяет являеться ли сумма цифр введённого целого трёхзначного числа чётным числом
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Решить с помощью Паскаля две задачи: 1. Составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом. 2.
Ответы (1)