Задать вопрос
31 июля, 06:06

Решить с помощью Паскаля две задачи:

1. Составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом.

2. Составить программу, которая определяет, верно ли, что в заданном числе все цифры стоят по возрастанию.

+2
Ответы (1)
  1. 31 июля, 08:54
    0
    Program gt;

    var n:integer;

    function chik (n:integer) : integer;

    var s, q:integer;

    begin

    s:=0;

    while n>0 do

    begin

    q:=n mod 10;

    n:=n div 10;

    s:=s+q;

    end;

    chik:=s;

    end;

    begin

    read (n) ;

    if (chik (n) mod 2=0) then writeln ('yes') else writeln ('no') ;

    end.

    2)

    program gt;

    var n, q, k, r:integer;

    begin

    read (n) ;

    k:=0; r:=-1;

    while n>0 do

    begin

    q:=n mod 10;

    n:=n div 10;

    if (q>=r) and (r-1) then k:=1;

    r:=q;

    end;

    if (k=0) then writeln ('yes') else writeln ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить с помощью Паскаля две задачи: 1. Составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Как составить программу, которая определяет является ли сумма цифр введённого целого трёхзначного числа четным числом?
Ответы (1)