Задать вопрос
11 февраля, 06:07

Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные

Входная строка содержит одно натуральное число.

Выходные данные

Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

+5
Ответы (1)
  1. 11 февраля, 08:19
    0
    Var

    s:string;

    i:longint;

    t:boolean;

    begin

    read (s) ;

    t:=false;

    for i:=1 to length (s) - 1 do

    if s[i]=s[i+1] then t:=true;

    if t then writeln ('YES') else writeln ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Программа в C++ Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел. Входные данные Входная строка содержит единственное число - требуемое количество чисел N.
Ответы (1)
В PascalABC Напишите программу, которая выводит все простые числа в диапазоне от K до N (2 ≤ K ≤ N ≤ 100000), у которых первая и последняя цифры десятичной записи одинаковые.
Ответы (1)