Задать вопрос
8 декабря, 17:00

Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры

Пример ввода:

375

Пример вывода:

Сумма цифр числа 375 равна 15

2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а. Значение а введите с клавиатуры

Пример ввода:

375

Пример вывода:

573

+4
Ответы (1)
  1. 8 декабря, 18:47
    0
    var

    a:integer;

    begin

    readln (n) ;

    writeln ('Сумма цифр числа ', a,' равна', a div 100 + (a mod 100) div 10 + a mod 10) ;

    end.

    var

    a:integer;

    begin

    readln (n) ;

    writeln ((a mod 10) * 100 + ((a mod 100) div 10) * 10 + a div 100) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Составьте программу вычисления суммы цифр двузначного числа а. Значение а введите с клавиатуры Пример ввода: 35 Пример вывода: Сумма цифр числа 35 равна 8
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)
Составьте программу ввода с клавиатуры элементов массива a[1 ... 8] и вывода элементов массива в обратном порядке (пример ввода: 1 2 3 4 5 6 7 8 пример вывода 8 7 5 4 3 2 1
Ответы (1)