Задать вопрос
9 июня, 02:34

Помогите:

Практическая работа №3. Ветвления

Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них.

Пример:

Введите два числа: 1 5

Наименьшее число 1

Наибольшее число 5

Уровень B. Напишите программу, которая получает с клавиатуры четыре целых числа и находит наибольшее из них.

Пример:

Введите четыре числа: 1 2 5 3

Наибольшее число 5

Уровень C. Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше.

Пример:

Возраст Антона: 15

Возраст Бориса: 17

Возраст Виктора: 16

Ответ: Борис старше всех.

Пример:

Возраст Антона: 17

Возраст Бориса: 17

Возраст Виктора: 16

Ответ: Антон и Борис старше Виктора.

На языке паскаль.

+2
Ответы (1)
  1. 9 июня, 05:01
    0
    Program p1;

    var a, b:integer;

    begin

    writeln ('Введите 2 числа') ;

    readln (a, b) ;

    if a=b then writeln ('Числа одинаковые')

    else if a>b then

    begin writeln ('Наибольшее число ', a) ;

    writeln ('Наименьшее число ', b) ;

    end

    else begin writeln ('Наибольшее число ', b) ;

    writeln ('Наиментшее число 10 ', a) ;

    end;

    end.

    program p2;

    var a, b, c, d:integer;

    begin

    writeln ('Введите 4 числа') ;

    readln (a, b, c, d) ;

    if a
    if c
    if a
    writeln ('Наибольшее число ', a) ;

    end.

    program p3;

    var a, b, v:integer;

    begin

    writeln ('Введите возрасты людей:') ;

    write ('Антона - ') ;

    readln (a) ;

    write ('Бориса - ') ;

    readln (b) ;

    write ('Виктора - ') ;

    readln (v) ;

    if (a=b) and (a=v) then writeln ('Все люди одного возраста') ;

    if (a=b) and (a>v) then writeln ('Антон и Борис старше Виктора') ;

    if (a=b) and (a
    else if (v>a) and (v>b) then writeln ('Виктор старше всех') ;

    if (b=v) and (b>a) then writeln ('Борис и Виктор старше Антона') ;

    if (b=v) and (b
    else if (a>v) and (a>b) then writeln ('Антон старше всех') ;

    if (a=v) and (a>b) then writeln ('Антон и Виктор старше Бориса') ;

    if (a=v) and (a
    else if (b>v) and (b>a) then writeln ('Борис старше всех') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести последовательно возраст Антона, Бориса и Виктора. Определить, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех. На C + + или Паскаль.
Ответы (1)
Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех.
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)