Задать вопрос
24 октября, 10:13

Дано {1/1, 2/1, 3/2, 5/3, 8/5, 13/8 ... } Нужно вывести первые n членов последовательности и посчитать k член на паскале

+3
Ответы (1)
  1. 24 октября, 10:33
    0
    {общий член последовательности можно задать формулой Sn = ((An-1) + (Bn-1)) / (An-1) где A - числитель, В - знаменатель }

    const n=10;

    var A, B, C, i, k: integer;

    begin

    A:=1; B:=1;

    { вывод последовательности на экран }

    for i:=2 to n do

    begin

    C:=A; A:=A+B; B:=C;

    writeln (i,' - > ', A,'/', B) ;

    end;

    { подсчет k - го члена }

    k:=20; A:=1; B:=1;

    for i:=2 to k do

    begin

    C:=A; A:=A+B; B:=C;

    end;

    writeln (k,' - ый элемент = ', A,'/', B) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано {1/1, 2/1, 3/2, 5/3, 8/5, 13/8 ... } Нужно вывести первые n членов последовательности и посчитать k член на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано натуральное n и последовательность чисел x1, x2, ..., xn. Вычислить среднее арифметическое членов последовательности. В первой строке содержится целое число n (1≤n≤100) - количество членов последовательности.
Ответы (1)
1. дано действительное число x и целое число n вывести N первых челнов арифметическойкой прогрессии и найти сумму ее первых членов если первый член X а разность 1,12 2.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)