Задать вопрос
25 декабря, 20:18

Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех.

+5
Ответы (1)
  1. 25 декабря, 23:29
    0
    Program prog;

    uses crt;

    var a, b, v:integer;

    begin

    clrscr;

    write ('Возраст Антона = ') ;

    readln (a) ;

    write ('Возраст Бориса = ') ;

    readln (b) ;

    write ('Возраст Виктора = ') ;

    readln (v) ;

    writeln;

    if (a>b) and (a>v) then writeln ('Антон старше всех.') ;

    if (b>a) and (b>v) then writeln ('Борис старше всех.') ;

    if (v>a) and (v>b) then writeln ('Виктор старше всех.') ;

    if (a=b) and (a>v) then writeln ('Антон и Борис старше Виктора') ;

    if (a=v) and (a>b) then writeln ('Антон и Виктор старше Бориса') ;

    if (b=v) and (b>a) then writeln ('Борис и Виктор старше Антона') ;

    if (a=b) and (a=v) then writeln ('Антон, Борис и Виктор одного возраста') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше. Пример: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Ввести последовательно возраст Антона, Бориса и Виктора. Определить, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех. На C + + или Паскаль.
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень D (на дополнительную оценку, не обязательная).
Ответы (1)
1) Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.
Ответы (1)