Задать вопрос
3 мая, 23:12

Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень D (на дополнительную оценку, не обязательная). Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

+3
Ответы (1)
  1. 3 мая, 23:58
    0
    Уровень C

    #include

    using namespace std;

    int main ()

    {

    int n;

    cin >> n;

    int maxdigit = 0;

    while (n > 0) {

    int digit = n % 10;

    if (digit > maxdigit)

    maxdigit = digit;

    n / = 10;

    }

    cout << maxdigit;

    return 0;

    }

    Уровень D

    #include

    using namespace std;

    int main () {

    int n;

    cin >> n;

    int prev = - 1;

    while (n > 0) {

    int digit = n % 10;

    if (digit = = prev) {

    cout << "YES";

    return 0;

    }

    prev = digit;

    n / = 10;

    }

    cout << "NO";

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.
Ответы (1)
Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)