Задать вопрос
14 октября, 06:41

1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

+2
Ответы (1)
  1. 14 октября, 10:28
    +1
    1. var a, tmp:integer;

    var b:boolean;

    begin

    b:=false;

    readln (a) ;

    tmp : = a mod 10; a: = a div 10;

    while a > 0 do

    begin

    if tmp = a mod 10 then b : = true

    else tmp : = a mod 10;

    a : = a div 10;

    end;

    writeln (b) ;

    end.

    2. var a, i:integer;

    var t:array[0 ... 9] of integer;

    var b:boolean;

    begin

    b:=false;

    readln (a) ;

    while a > 0 do

    begin

    inc (t[a mod 10]) ;

    a : = a div 10;

    end;

    for i:=0 to 9 do if t[i] > 1 then b : = true;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите создвть программу в python. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом). (p. s.
Ответы (1)
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)