Задать вопрос
3 октября, 21:02

Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

Пример:

Введите целое число: Введите целое число:

1232 1224

Нет. Да.

Через ветвление, while, repeat, until

+3
Ответы (1)
  1. 3 октября, 22:59
    0
    Var A:longint;

    k:byte;

    Begin

    k:=0;

    WriteLn ('Введите целое число: ') ; ReadLn (A) ;

    While A div 10 0 do

    Begin

    if (A div 10) mod 10 = A mod 10 then k:=1;

    A:=A div 10

    End;

    if k = 1 then Write ('Да.')

    else Write ('Нет.')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)
Помогите создвть программу в python. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом). (p. s.
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)