Задать вопрос
25 октября, 23:32

Написать программу Заполнить массив из 15 элементов случайными числами (-20; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов

+3
Ответы (1)
  1. 26 октября, 00:39
    0
    const

    n = 15;

    var

    a:array[1 ... n] of integer;

    i, Count, Summ:integer;

    begin

    randomize;

    Count : = 0;

    Summ : = 0;

    for i : = 1 to n do

    begin

    a[i] : = random (101) - 20;

    write (a[i], ' ') ;

    inc (Summ, a[i]) ;

    if a[i] < 0 then

    inc (count) ;

    end;

    writeln;

    writeln ('Summ = ', Summ) ;

    writeln ('Count = ', count) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу Заполнить массив из 15 элементов случайными числами (-20; 80) Посчитать сумму всех элементов массива Посчитать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)