Задать вопрос
3 мая, 21:31

В подвале школы потоп. N литров воды оказалось в зоне потопа. У учащихся, помогающих устранить потоп, имеются ведра вместимостью 12 литров. Сколько вёдер воды нужно вынести, чтобы полностью устранить потоп в школе

+4
Ответы (1)
  1. 3 мая, 21:39
    0
    Program n1;

    var n: integer;

    begin

    readln (n) ;

    if n mod 12 = 0 then writeln ('надо вынести ', n div 12, ' ведер')

    else writeln ('надо вынести ', (n div 12) + 1, ' ведер') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В подвале школы потоп. N литров воды оказалось в зоне потопа. У учащихся, помогающих устранить потоп, имеются ведра вместимостью 12 литров. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу на языке программирования Pascal В подвале школы потоп. N литров воды оказалось в зоне потопа. У учащихся, помогающих устранить потоп, имеются ведра вместимостью 12 литров.
Ответы (1)
1) Имеются семилитровая банка сока и 2 пустых банки: трех - и четырехлитровая. Как налить в трехлитровую банку 2 литра сока? 2) Имеются три бочонка вместимостью 6 ведер, 3 ведра, 7 ведер.
Ответы (1)
Ученики третьего класса собирали яблоки, первый ученик собрал x вёдер, второй собрал y вёдер, третий собрал n вёдер яблок. Сколько вёдер яблок собрали ученики?
Ответы (1)
Есть три пустых ведра: 8 литров, 5 литров и 3 литра. 8-литровое ведро наполнено водой, два других пустые. Как напоить двух лошадей, дав каждой по 4 литра воды. Команды; налить в ведро, вылить из ведра, перелить из одного ведра в другое.
Ответы (1)
Маляру необходимо выкрасить стену дома. Ему выдали ведро с 12 л краски. Но так как стена высокая, он может поднять на высоту только 6 литров и хочет отлить из ведра ровно половину, но у него нет емкости вместимостью в 6 л.
Ответы (1)