Задать вопрос
3 февраля, 15:54

Помогите составить программу на языке программирования Pascal

В подвале школы потоп. N литров воды оказалось в зоне потопа. У учащихся, помогающих устранить потоп, имеются ведра вместимостью 12 литров. Сколько вёдер воды нужно вынести, чтобы полностью устранить потоп в школе

+5
Ответы (1)
  1. 3 февраля, 17:38
    0
    Program n1;

    var n: integer;

    begin

    readln (n) ;

    if n mod 12 = 0 then writeln ('надо вынести ', n div 12, ' ведер')

    else writeln ('надо вынести ', (n div 12) + 1, ' ведер') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу на языке программирования Pascal В подвале школы потоп. N литров воды оказалось в зоне потопа. У учащихся, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В подвале школы потоп. N литров воды оказалось в зоне потопа. У учащихся, помогающих устранить потоп, имеются ведра вместимостью 12 литров. Сколько вёдер воды нужно вынести, чтобы полностью устранить потоп в школе
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
1) Имеются семилитровая банка сока и 2 пустых банки: трех - и четырехлитровая. Как налить в трехлитровую банку 2 литра сока? 2) Имеются три бочонка вместимостью 6 ведер, 3 ведра, 7 ведер.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)