Задать вопрос
2 ноября, 01:33

1) Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. 2) Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Сделайте в Паскале Pascal

+3
Ответы (1)
  1. 2 ноября, 02:50
    0
    1

    program odin;

    uses crt;

    var x, y, z:real;

    begin

    clrscr;

    read (x) ;

    y:=x mod 10;

    z:=x div 10;

    if y>z then

    writeln (y)

    else

    writeln (z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. 2) Напишите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень D (на дополнительную оценку, не обязательная).
Ответы (1)
Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)