Задать вопрос
11 февраля, 12:54

1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1.

Вход: программа получает на выход кол-во чисел, а затем сами числа. Кол-во чисел не превышает 1000, а сами числа не превышают 30000.

Выход: программа должна вывести YES, если в последовательности есть хотя бы одно нечетное число не оканчивающиеся на 1 и NO в противном случае.

2) Напишите программу, которая в последовательности натуральных чисел находимо кол-во нечетных чисел кратных 3.

Вход: программа получает на выход кол-во чисел, а затем сами числа. Кол-во чисел не превышает 1000, а сами числа не превышают 30000.

Выход: Программа должна вывести одно число-кол-во нечётных чисел кратных 3.

+4
Ответы (2)
  1. 11 февраля, 14:47
    0
    1)

    var

    x, n, i: integer;

    flag: boolean;

    begin

    read (n) ;

    flag : = false;

    for i : = 1 to n do

    begin

    read (x) ;

    if ((x mod 10 1) and (x mod 2 0)) then

    begin

    flag : = true;

    break;

    end;

    end;

    if (flag) then write ('YES')

    else write ('NO')

    end.

    2)

    var

    x, n, i, count: integer;

    begin

    count : = 0;

    read (n) ;

    for i : = 1 to n do

    begin

    read (x) ;

    if ((x mod 3 = 0) and (x mod 2 0)) then count : = count + 1;

    end;

    write (count) ;

    end.
  2. 11 февраля, 15:00
    0
    1.

    var

    a, k, i, c: integer;

    begin

    c:=0;

    write ('Введите количество чисел в последовательности: ') ;

    readln (k) ;

    for i : = 1 to k do

    begin

    write ('Введите число: ') ;

    readln (a) ;

    if (a mod 2 = 1) and (a mod 10 1) then c:=c+1

    end;

    if c>0 then writeln ('YES')

    else writeln ('NO')

    end.

    2.

    var

    a, k, i, c: integer;

    begin

    c:=0;

    write ('Введите количество чисел в последовательности: ') ;

    readln (k) ;

    for i : = 1 to k do

    begin

    write ('Введите число: ') ;

    readln (a) ;

    if (a mod 2 = 1) and (a mod 3 = 0) then c:=c+1

    end;

    writeln (c)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Нужно написать программу на PascalABC Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)