Задать вопрос
2 ноября, 01:31

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6. Программа получает на вод натуральные числа, кол-во введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Программа должна вывести одно число: сумма четырехзначных чисел, кратных 6.

2) Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратно 3 и оканчивающиеся на 3. программа получает на вход кол-во чисел в последовательности, а заем сами числа. В последовательности всегда имеется число, кратное 3 и оканчивающиеся на 3. Кол-во чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число - максимальное число, кратное 3 и оканчивающиеся на 3.

+3
Ответы (1)
  1. 2 ноября, 04:25
    0
    1)

    Program n1;

    var a: integer;

    sum: real;

    begin

    readln (a) ;

    sum:=0;

    while a0 do

    begin

    if (a>999) and (a<10000) and (a mod 6=0) then sum:=sum+a;

    readln (a) ;

    end;

    writeln (sum) ;

    end.

    2)

    Program n2;

    var a, max, i, n: integer;

    begin

    readln (n) ;

    max:=-30000;

    for i:=1 to n do

    begin

    readln (a) ;

    if (a>max) and (a mod 3=0) and (a mod 10=3) then max:=a;

    end;

    writeln (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6. Программа получает ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)